Account Contact
Your Cart
Pay on delivery – no extra fees
Need help? Ask our AI

D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey

D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
60 mo.
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
R11,671
Enjoy the Power of Next-Gen Surveillance SwitchEnhance your surveillance environment with the DSS-200G, a smart and easily installed device that delivers greater control and flexibility. Discover the capabilities of this intelligent tool that automates processes and adds intelligence to your network... Read More
Stock 1 Code 2409140 Brand D-LINK Model DSS-200G-28MPP Warranty 5 Years

Shipping & Returns

Estimated delivery Tuesday, October 27
You will be kept updated through our detailed tracking system
Payment options
EFTPayFastBank CardSnapScanZapperGoogle PayApple PayMobicredMoreTymePay on Arrival
Enjoy the Power of Next-Gen Surveillance Switch
Enhance your surveillance environment with the DSS-200G, a smart and easily installed device that delivers greater control and flexibility. Discover the capabilities of this intelligent tool that automates processes and adds intelligence to your network.

Built for Surveillance,
with Gigabit Ethernet & PoE++

Designed to meet surveillance requirements for businesses of all sizes, with features like support for high-powered PTZ cameras, high PoE budgets, Auto Surveillance VLAN, and surge protection, these switches are ideal for IP surveillance setups.

Long Range PoE Delivery
Connect and power cameras up to 250 metres away without the need for additional PoE extenders.

Power Your Devices
Supports PoE/PoE+ to connect and power your PoE-cable network devices via Ethernet cables without the need for power adapters.

Reliable PoE Connections
Surge protection on all PoE ports protects the switch when feeding power to PoE-capable devices.

Rapid deployments with a single PoE cable.
The series supports PoE, and some provide higher power PoE++, delivering up to 90 watts on selected ports, enabling faster deployment of PoE devices such as IP cameras, VoIP phones, access points, terminals, speakers, lights, conferencing systems, displays, and more.

Reach further with a flick of a switch.
The built-in DIP switch allows easy configuration and quick adjustment of application settings without the need to access the web configuration. Quickly enable and disable functions such as QoS, Extend (connection by up to 250 metres), Port Isolation, PD-Alive and STP (Spanning Tree Protocol) in an instant.

Protects the network against power surges.
6kV surge protection on all PoE ports protects the network against voltage spikes with link aggregation, ERPS and STP support to make your network more robust and resilient.

Connect to more with PoE++
See your remaining power availability with the built-in PoE Power Budget LEDs for 25%, 50%, 75%, and 100% power usage at a glance. And utilise up to 518W, with 90W on 8 ports and 30W on 15 ports for DSS-200G-28MPP, so you can rapidly deploy more devices.

Layer 2 management features.
Comes with a complete line-up of L2 features, including port mirroring, Spanning Tree Protocol (STP), and Link Aggregation Control Protocol (LACP). Network maintenance features such as loopback detection and cable diagnostics.

Quality of Service and bandwidth control.
Bandwidth control allows network administrators to reserve bandwidth for important functions that require higher priority or more bandwidth.

Auto Surveillance VLAN consolidates data and surveillance video transmission through a single switch, sparing businesses the expense of dedicated hardware and facilities.

Voice VLAN enhances the VoIP service by automatically placing voice traffic from IP phones to a designated VLAN. With a prioritised and segmented VLAN, this feature guarantees quality and security of VoIP traffic.

Energy efficient
With built-in D-Link Green technology, this series saves power without sacrificing operational performance or functionality.

Time-Based PoE
Schedule the ports on the switch to provide PoE power to devices on specific days and during set hours of the week for energy savings

Sleep mode
Link status drastically reduces power consumption by automatically putting ports without a link into a sleep mode

Advanced chipset
The series incorporates a special chipset with advanced silicon technology for efficient use of energy

We're here to help.
Over 35 years in the networking industry

Innovative end-to-end solution experts for small businesses to large corporations around the world.

Talking to us is easy
Skilled local support in 16 countries. Our support teams are ready to help you.

D-Link DSS-200G-28MPP. Switch type: Managed, Switch layer: L2. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 24. Full duplex. MAC address table: 8000 entries, Switching capacity: 56 Gbit/s. Networking standards: IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3bt,.... Power over Ethernet (PoE). Form factor: 1U

Key Highlights
  • High PoE budgets and support for IEEE 802.3bt 90 W PoE
  • 6 kV surge protection on all PoE ports
  • Alarm Port and four-stage PoE usage indicator light
  • Smart Fan design
  • Surveillance traffic optimization
  • Auto-detect ONVIF devices
  • Built-in SNMP MIB
  • Surveillance VLAN
  • Easy deployment with automatic configuration
  • Managed L2 Web-based management
  • Quality of Service (QoS) support
  • Basic switching RJ-45 Ethernet ports quantity: 24
  • MAC address table: 8000 entries Switching capacity: 56 Gbit/s Controllable multicast
  • 1U
  • AC Power supply included Power over Ethernet (PoE)
Specifications
AC input frequency
50/60 Hz
AC input voltage
100 - 240 V
Auto MDI/MDI-X
Yes
Auto-negotiation
Yes
Basic switching RJ-45 Ethernet ports quantity
24
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Broadcast storm control
Yes
Combo SFP ports quantity
4
Compliance certificates
BSMI, CB, CE, Federal Communications Commission (FCC), Low Voltage Directive (LVD), UL, cUL
Depth
330 mm
Ethernet LAN data rates
1000 Mbit/s
Fanless
No
Flash memory
32 MB
Flow control support
Yes
Form factor
1U
Forwarding rate
41.67 Mpps
Full duplex
Yes
Half duplex
Yes
Head-of-line (HOL) blocking
Yes
Heat dissipation
209.16 BTU/h
Height
44 mm
IGMP snooping
Yes
Input current
6.4 A
Input voltage
100 - 240 V
Internal memory
128 MB
Jumbo frames
10240
Jumbo frames support
Yes
LED indicators
Activity, Alarm, Link, Power, Speed
Link aggregation
Yes
MAC address table
8000 entries
Mean time between failures (MTBF)
289075 h
Memory type
DDR3-SDRAM
MIB support
• RFC768 UDP • RFC791 IP • RFC792 ICMP • RFC793 TCP • RFC826 ARP • RFC1213 MIB II • RFC1493 Bridage MIB • RFC1907 SNMPv2 MIB • RFC1215 MIB Traps Convention • RFC2233 Interface Group MIB • RFC2665 Ether-like MIB • RFC4363 IEEE 802.1p MIB • ZoneDefense MIB • Private MIB • RFC951 BootP client • RFC1542 BootP/DHCP client • RFC2236 IGMP Snooping
Multicast features
Controllable multicast
Multicast support
Yes
Networking standards
IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az, IEEE 802.3bt, IEEE 802.3u, IEEE 802.3x
Noise level
54 dB
Number of fans
2 fan(s)
Number of queues
4
Number of VLANs
4094
Operating relative humidity (H-H)
0 - 95%
Operating temperature (T-T)
-5 - 50 °C
Packet buffer memory
4.1 MB
Password protection
Yes
Port mirroring
Yes
Power consumption (max)
579.3 W
Power over Ethernet (PoE)
Yes
Power over Ethernet (PoE) ports quantity
24
Power over Ethernet (PoE) power per port
30 W
Power source
AC
Power supply included
Yes
Product colour
Grey
Quality of Service (QoS) support
Yes
Queue scheduling algorithms
Strict Priority Queue (SPQ), Weighted Round Robin (WRR)
Rate limiting
Yes
Reset button
Yes
Spanning tree protocol
Yes
SSH/SSL support
Yes
Storage relative humidity (H-H)
0 - 95%
Storage temperature (T-T)
-40 - 70 °C
Sustainability compliance
Yes
Switch layer
L2
Switch type
Managed
Switching capacity
56 Gbit/s
Total Power over Ethernet (PoE) budget
518 W
Traffic classification
Yes
Virtual LAN features
Voice VLAN
VLAN support
Yes
Web-based management
Yes
Weight
4.71 kg
Width
440 mm

Leaflet

Open Leaflet
Price history over the last 6 months
D-Link DSS-200G-28MPP network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey
Current
R11,671
Lowest
R10,687
Highest
R13,764
Change 24H
+R213   +2%
Week
+R907   +8%
Month
+R257   +2%

Popular products in this category

WhatsApp
Hi, I’m DistriNode’s AI assistant. I can help you find products, compare options, create quote PDFs, or open support requests.